Single Homes FCoE Example

N7K-DC1-1-fcoe(config)# vsan data
N7K-DC1-1-fcoe(config-vsan-db)# vsan 100
N7K-DC1-1-fcoe(config-vsan-db)# vlan 100
N7K-DC1-1-fcoe(config-vlan)# fcoe vsan 100
N7K-DC1-1-fcoe(config-vlan)# exit
N7K-DC1-1-fcoe(config)# sh vlan fcoe

Original VLAN ID Translated VSAN ID Association State
—————- —————— —————–

100 100 Operational

N7K-DC1-1-fcoe(config-if)# int vfc 71
N7K-DC1-1-fcoe(config-if)# bind int e 7/1
N7K-DC1-1-fcoe(config-if)# show int vfc 71
vfc71 is trunking
Bound interface is Ethernet7/1
Hardware is Ethernet
Port WWN is 20:46:00:26:98:2f:67:bf
Admin port mode is F, trunk mode is on
snmp link state traps are enabled
Port mode is TF
Port vsan is 1
Speed is auto
Trunk vsans (admin allowed and active) (100)
Trunk vsans (up) ()
Trunk vsans (isolated) ()
Trunk vsans (initializing) (100)
0 fcoe in packets
0 fcoe in octets
0 fcoe out packets
0 fcoe out octets
Interface last changed at Fri Mar 29 17:11:18 2013

N7K-DC1-1-fcoe(config-if)# sh run int e 7/1

!Command: show running-config interface Ethernet7/1
!Time: Fri Mar 29 17:20:42 2013

version 6.0(4)

interface Ethernet7/1
switchport mode trunk
no shutdown

N7K-DC1-1-fcoe(config-if)#

 

 

UCS : Action on Uplink Fail.

There is a possiblity to have a failover of the NIC without notification of the OS.

UCS_Failover

  • Link Down— Changes the operational state of a vNIC to down when uplink connectivity is lost on the fabric interconnect, and enables fabric failover for vNICs.
  • Warning— Maintains server-to-server connectivity even when no uplink port is available, and disables fabric failover when uplink connectivity is lost on the fabric interconnect.

FI Chassis discovery

At Equipment / Policies you can configure how many links between the chassis and FI should be present before the UCSM will discover a new chassis.

If you put the value at 2 and you only have one link you will receive :

 

 

FI-1LinkOnly

FI FC connected to N5K

feature npiv
feature fport-channel-trunk

slot 1
port 31-32 type fc

 

vsan database
vsan 88

 

interface fc1/31
switchport mode F
channel-group 3 force
no shutdown

interface fc1/32
switchport mode F
channel-group 3 force
no shutdown
interface san-port-channel 3
channel mode active
switchport mode F
switchport trunk allowed vsan 88

 

vsan database
vsan 88 interface san-port-channel 3

vPC+ at the spine

•Raise the FP IS-IS metric for VPC+ Peer-Link to prefer other FP core links :

Interface Po1
fabricpath isis metric 200

vPC+ & STP.

vPC+ should be the root of the vlan.

spanning-tree vlan 10 priority 32778

The Switch south should have a different priority

spanning-tree vlan 10 priority 61440

•Set the best STP priority (for all VLAN allowed on vPC+ member ports) on both vPC+ peer devices:
spanning-tree vlan 10-100 priority 4096
•FP technology enables by default STP root guard-like on CE edge ports. There is no need to explicitly configure root guard on vPC+ member ports.

vPC+

Emulated “Switch 4” becomes egress
switch for Host A in FabricPath domain

S1 S2
feature vpc

 

vlan 1-23

mode fabricpath

 

vpc domain 100

peer-keepalive destination 172.26.246.86 source 172.26.246.85

  fabricpath switch-id 4

 

interface port-channel100

vpc peer-link

interface port-channel1

vpc 1

 

fabricpath domain default

fabricpath switch-id 1

feature vpc

 

vlan 1-23

mode fabricpath

 

vpc domain 100

peer-keepalive destination 172.26.246.85 source 172.26.246.86

fabricpath switch-id 4

 

interface port-channel100

vpc peer-link

interface port-channel1

vpc 1

 

fabricpath domain default

fabricpath switch-id 2

FabricPath Facts

Switch with highest priority value becomes root for primary tree

Highest system ID, then highest Switch ID value, in case of a tie.

 

S100(config)# vlan 10

S100(config-vlan)# mode ?

ce          Classical Ethernet VLAN mode

fabricpath  Fabricpath VLAN mode

 

S100(config-vlan)# mode fabricpath

S100(config-vlan)#

FCIP between MDS

feature fcip

fcip profile 1

ip address 10.10.200.2

fcip profile 2
ip address 10.10.200.6

vsan database
vsan 100
vsan 200
interface fcip1
use-profile 1
peer-info ipaddr 10.10.200.1
switchport trunk allowed vsan 100
switchport trunk allowed vsan add 200
no shutdown

interface fcip2
use-profile 2
peer-info ipaddr 10.10.200.5
switchport trunk allowed vsan 100
switchport trunk allowed vsan add 200
no shutdown

interface GigabitEthernet2/3

ip address 10.10.200.2 255.255.255.252
switchport mtu 2300 (As long as the value > 2242)
no shutdown

interface GigabitEthernet2/4
ip address 10.10.200.6 255.255.255.252
switchport mtu 2300
no shutdown

MDS-2# sh fcip sum

——————————————————————————-
Tun prof Eth-if peer-ip Status T W T Enc Comp Bandwidth rtt
E A A max/min (us)
——————————————————————————-
1 1 GE2/3 10.10.200.1 TRNK Y N N N N 1000M/500M 1000
2 2 GE2/4 10.10.200.5 TRNK Y N N N N 1000M/500M 1000

 

Guidelines for OTV Multicast

OTV has the following guidelines for multicast configuration:

  • OTV does not require Protocol Independent Multicast (PIM) to be configured on an edge device. If you configure PIM on the edge device, ensure that the rendezvous point (RP) is also configured on the edge device. The reverse-path forwarding (RPF) interface for (*.PG) should be join interface.

 

  • Do not configure PIM on a join interface of the edge device.

 

  • You should configure IGMP version 3 on both sides of the join interface link. The OTV edge devices send IGMP (S,G) joins the edge devices in other sites in the same VPN. If you must configure IGMPv2, you must configure the last-hop router to do an ssm-translate, and the data-group range for the overlay interface must be SSM.

 

  • You can directly connect edge devices in different sites.

 

  • If there is no router in the site, you must configure the ip igmp snooping querier command in VLAN configuration mode on the switch.

 

  •  IGMP snooping for VLANs extended over the overlay network is enabled by default and should not be disabled. IGMP reports that are originated in the site are not sent across the core. Enough multicast state is built in the edge devices and core routers so that traffic can be sent from the source in the source site to a destination in the destination site.

 

  • You do not need to configure a unicast routing protocol on join interfaces, although in most situations, one will be configured.

 

 

 

  • You must disable optimized multicast forwarding (OMF) in IGMP snooping in OTV edge devices for IPv6 unicast or multicast traffic to flow across an OTV overlay network.