Creating a Storage VDC

N7K-DC1-1(config)# vdc N7K-DC1-2 type storage
ERROR: Feature-set not installed
N7K-DC1-1(config)# install feature-set fcoe

N7K-DC1-1(config)# vdc N7K-DC1-2 type storage

Note: Creating VDC, one moment please …
2013 Mar 21 09:29:11 %$ VDC-2 %$ %FEATURE-MGR-2-FM_FSET_PRESEQ_REJECT: It rejects pre-sequence due to a service with sap 377: Active template not fcoe compatible, to enable feature-set fcoe, apply non-8e network-qos policy

And now you’ll have to wait about 20 minutes or try to break it. (Takes serveral minutes)

Better is to have in advance :

system qos

 service-policy type network-qos default-nq-7e-policy 

 

With this command configured it should look like and it should some seconds:

N7K-DC1-1(config)# vdc N7K-DC1-2 type storage
Note: Creating VDC, one moment please …
N7K-DC1-1(config-vdc)# 2013 Mar 21 09:40:37 N7K-DC1-1 %$ VDC-1 %$ %VDC_MGR-2-VDC_ONLINE: vdc 2 has come online

N7K-DC1-1(config-vdc)#

Verify OTV configuration

N7K-1-OTV-1A(config-if-overlay)# show running-config otv

feature otv
otv site-vlan 1005
interface Overlay1
otv join-interface Ethernet1/10
otv control-group 239.1.1.1
otv data-group 239.1.2.0/28
otv extend-vlan 131, 151, 171
no shutdown
otv site-identifier 0x1

 

Summary of Commands :

feature otv
otv site-vlan 1005
otv site-identifier 0x1
interface Overlay 1
otv control-group 239.<X>.1.1
otv data-group 239.<X>.2.0/28
otv join-interface Ethernet1/<uplink>
otv extend-vlan 131,151,171,211
no shutdown

 

N7K-1-OTV-1A(config-if-overlay)# show otv overlay 1
OTV Overlay Information
Site Identifier 0000.0000.0000
Overlay interface Overlay1
VPN name : Overlay1
VPN state : UP
Extended vlans : 131 151 171 211 (Total:4)
Control group : 239.1.1.1
Data group range(s) : 239.1.2.0/28
Join interface(s) : Eth1/10 (10.1.11.3)
Site vlan : 1005 (up)
AED-Capable : Yes
Capability : Multicast-Reachable

N7K-1-OTV-1A(config-if-overlay)# sh otv site
Site Adjacency Information (Site-VLAN: 1005) (* – this device)
Overlay1 Site-Local Adjacencies (Count: 2)
Hostname System-ID Up Time Ordinal
——————————– ————– ——— ———-

* N7K-1-OTV-1A 0026.980d.6d42 00:05:58 0
N7K-2-OTV-1B 0026.980d.92c2 00:05:37 1

 

N7K-1-OTV-1A# show otv adjacency
Overlay Adjacency database
Overlay-Interface Overlay1 :
Hostname System-ID Dest Addr Up Time State
N7K-2-OTV-1B 0026.980d.92c2 10.1.14.4 1w2d UP

OTV Site Identifier

Configure the site identifier. We will use 0x1 for Site A on N7K-1.
otv site-identifier 0x1
OTV uses the site identifier to support dual site adjacency. Dual site adjacency uses both site VLAN and  site identifier to determine if there are other edge devices on the local site and if those edge devices can forward traffic. Ensure that the site identifier is the same on all neighbor edge devices in the site.
You must configure the site identifier in Cisco NX-OS release 5.2(1) or later releases.

The overlay network will not become operational until you configure the site identifier.

The Site-VLAN and site identifier must be configured before entering the no shutdown command for any  interface overlay and must not be modified while any overlay is up within the site.

MTU Size OTV

We increased the MTU on the layer 3 links to 9042 bytes. OTV encapsulates the original frame adding 42 bytes to your IP packet, so you will need to increase the MTU on all your WAN links.

Since the MTU on the core has already been adjusted to 9042, you will get an OSPF state of EXSTART until your MTU matches the core MTU.

OTV encapsulates packets into an IP header and where it sets the Don’t Fragment (DF) bit for all OTV control and data packets crossing the transport network. The encapsulation adds 42 bytes to the original IP maximum transition unit (MTU) size. So it is a best practice to configure the join interface and all Layer 3 interfaces that face the IP core between the OTV edge devices with the max possible MTU size supported by the transport.

Basic OSPF on a N7K

feature ospf

router ospf 1

log-adjacency-changes

int loop 0

ip add 10.1.0.11/32

ip router ospf 1 area 0.0.0.0

int e 1/10

ip add 10.1.11.1/24

ip ospf network point-to-point

ip router ospf 1 area 0.0.0.0

no shut

 

show running-config ospf

show ip ospf int brief

show ip ospf neighbors

Spanning-tree priority

The lower the priority, it will be prefered.

 

spanning-tree vlan 131,151 priority 4096

 

Configure Zones on N5K

sh flogi database for some wwpn

device-alias database

device-alias name NTAP1-A_0a pwwn <ntap1_a_wwpn>

device-alias name ESX1_NTAP1-A_A pwwn <esx1_a_wwpn>
device-alias name ESX2_NTAP1-A_A pwwn <esx2_a_wwpn>
device-alias name ESX3_NTAP1-A_A pwwn <esx2_a_wwpn>
exit
device-alias commit

 

zone name ESX1_NTAP1-A_A vsan 11
member pwwn 21:00:00:c0:dd:12:bc:6d
member pwwn 50:0a:09:81:88:bc:c3:04

zoneset name FLEXPOD_A vsan 11
member ESX1_NTAP1-A_A
member ESX2_NTAP1-A_A
member ESX3_NTAP1-A_A
exit

zoneset distribute full vsan 11

zoneset activate name FLEXPOD_A vsan 11
Zoneset activation initiated. check zone status
N5K-1(config)# sh zoneset
zoneset name FLEXPOD_A vsan 11
zone name ESX1_NTAP1-A_A vsan 11
pwwn 21:00:00:c0:dd:12:bc:6d [ESX1_NTAP1-A_A]
pwwn 50:0a:09:81:88:bc:c3:04 [NTAP1-A_0a]

zone name ESX2_NTAP1-A_A vsan 11
pwwn 21:00:00:c0:dd:14:60:31 [ESX2_NTAP1-A_A]
pwwn 50:0a:09:81:88:bc:c3:04 [NTAP1-A_0a]

zone name ESX3_NTAP1-A_A vsan 11
pwwn 21:00:00:c0:dd:11:bc:e9 [ESX3_NTAP1-A_A]
pwwn 50:0a:09:81:88:bc:c3:04 [NTAP1-A_0a]

Configure San Port-channel on MDS

interface port-channel 111

channel mode active

switchport trunk allowed vsan 11

 

int fc 1/1-2

channel-group 111 force

no shut

 

vsan database

vsan 11 interface port-channel 111

 

Show vsan membership

 

FCoE on a N5K

vlan 1011

fcoe vsan 11

 

int po 13

switchport trunk allowed vlan add 1011

 

int vfc 13

bin int po 13

switchport trunk allowed vsan 11

no shut

 

vsan database

vsan 11 interface vfc 13

FC Port-channel on N5K

int san-port-channel 111

channel mode active

 

interface fc 2/3-4

channel-group 111

no shut

 

int san-port-channel 111

switchport trunk mode auto

switchport trunk allows vsan 11

 

vsan database

vsan 11 name Fabric_1

vsan 11 interface san-port-channel 111

exit